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ApSIC Xbench allows you to organize and search your bilingual 
reference terminology. ApSIC Xbench also features several Quality 
Assurance (QA) checks to boost the quality of your translations. 

Search features 

ApSIC Xbench allows you to perform powerful searches on the following 
bilingual formats: 

� Tab-delimited text files (*.txt) 

� XLIFF files (*.xlf, *.xlif, *.xliff) 

� TMX memories (*.tmx) 

� TBX/MARTIF glossaries (*.xml, *tbx, *.mtf) 

� Trados exported memories (*.txt) 

� Trados exported MultiTerm 5 glossaries (*.txt) 

� Trados MultiTerm XML glossaries (*.xml) 

� Trados TagEditor files (*.ttx) 

� Trados Word uncleaned files (*.doc, *.rtf) 

� Trados Studio files (*.sdlxliff, *.sdlproj) 

� SDLX ITD files (*.itd). Note: This option requires that SDLX is 
installed on the machine.  

� SDLX Memories (*.mdb) 

� STAR Transit 2.6/XV directory tree 

� PO files (*.po) 

� IBM TranslationManager exported dictionaries (*.sgm) 

� IBM TranslationManager installed and exported folders (*.fxp)  

� IBM TranslationManager exported memories (*.exp) 

� OpenTM2 exported dictionaries (*.sgm) 

� OpenTM2 installed and exported folders (*.fxp)  

� OpenTM2 exported memories (*.exp) 

� Wordfast memories (*.txt) 

� Wordfast glossaries (*.txt) 

� Wordfast Pro TXML files 

� DejaVu X/Idiom files (*.wsprj, *.dvprj) 

� DejaVu X/Idiom memories (*.wstm, *.dvmdb) 

� Logoport RTF files (*.rtf) 

Overview 
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� Microsoft software glossaries (*.csv) 

� Mac OS X glossaries (*.ad) 

� Remote Xbench Server glossaries 

Reference terminology can be organized in several levels of priority to 
show clearly to translators the particular translation project preferences.  

ApSIC Xbench runs on the background and can be invoked to search for 
the currently marked text using a system-wide key combination (by 
default, Ctrl+Alt+Ins). This effectively provides instant terminology 
searches from within any Windows application using a common key 
combination. 

ApSIC Xbench features a very powerful search engine. Not only can you 
search by source or target text but also perform negative or conditional 
searches with the PowerSearch function (Ctrl+P) or perform complex 
searches using either the grammar for regular expressions or Microsoft 
Word wildcards.  

Note: After it is launched, ApSIC Xbench stays on the background until it 
is explicitly closed with the Shutdown Xbench command that is 
available either by right-clicking the icon on the Windows task bar or 
using the Project pull-down menu.  

QA features 

By defining your current translation files as ongoing translation in your 
ApSIC Xbench project, you can run the following QA checks: 

� Find untranslated segments 

� Find segments with the same source text and different target text 

� Find segments with the same target text and different source text 

� Find segments whose target text matches the source text (potentially 
untranslated text) 

� Find tag mismatches 

� Find number mismatches 

� Find double blanks 

� Find repeated words 

� Find terminology mismatches against a list of key terms 

� Execute user-defined checklists. 

� Spell-check translations (requires downloading the plugin for the 
language dictionary) 

Checklists are user-defined searches that you can run in batch against 
your ongoing translation. For example, with checklists you can search for 
banned words or typical translator pitfalls. 
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Installing and Uninstalling 
ApSIC Xbench 

To install ApSIC Xbench 

To install ApSIC Xbench, please do the following: 

Run the installation executable (for example, Setup.Xbench.2.9.exe). The 
installer welcome screen will appear. 

 

Click Next. The license window appears. Please read carefully the license 
information to ensure you accept its terms. 

If the terms of the license are acceptable to you, please click I Agree.  If 
they are not acceptable please click Cancel. 

C H A P T E R  1  
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Change the destination folder if necessary and click Install to continue. 

The files are copied to the selected destination and the following window 
appears. 

 

Click Finish to close the Window and start using ApSIC Xbench. 

A link to the ApSIC Xbench executable is installed on the Start-
>Programs->ApSIC Tools->Xbench path, together with the 
documentation. 
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To uninstall ApSIC 
Xbench 

To uninstall ApSIC Xbench, please do the following: 

1 Choose Start->Settings->Control Panel on the Windows task bar. 
Go to the Windows Control Panel and open the Add/Remove 
Programs icon. 

2 Look for ApSIC Xbench in the list and click the Change or Remove 
button. 

3 When you receive a confirmation message, click Yes. 
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Launching and Shutting 
Down ApSIC Xbench 

ApSIC Xbench is an application than once launched must be explicitly 
shut down when it is no longer needed.  In a normal scenario, you will 
load your reference project to search for terminology while you are 
translating and leave it in the background until you finish your translation 
work.  Closing the ApSIC Xbench window does not remove the program 
from the memory because it is waiting for your next query with the 
Ctrl+Alt+Ins key sequence. 

Launching ApSIC Xbench 

To launch ApSIC Xbench, follow one of these procedures: 

� Choose Start->Programs->ApSIC Tools->Xbench on the Windows 
task bar. 

� Double-click on the icon of a previously defined ApSIC Xbench 
project (.xbp extension). 

Shutting Down ApSIC 
Xbench 

In order to shutdown ApSIC Xbench, you have the following options: 

� Right-click the ApSIC Xbench icon (a pink gem) located in the 
system tray and click Shutdown Xbench. 

� On the Project menu, click Shutdown Xbench 
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In this section you will learn about ApSIC Xbench search features.  The 
following concepts are useful to understand how ApSIC Xbench works: 

Project: In ApSIC Xbench, a project is a definition of files and their 
priorities and relationships. The first thing you do in ApSIC Xbench is to 
define a project that includes the terminology you want to search -- and 
how to search it. 

Ongoing translation: ApSIC Xbench lets you mark a file or set of files as 
"ongoing translation" and then visually identify its strings in the search 
results. In addition, QA features can be performed only on files defined 
as ongoing translation. 

Checklist: In ApSIC Xbench a checklist is a battery of searches than can 
be run in batch. 

PowerSearch: This is a special search mode where you can define 
AND/OR conditions and negations to the search string to perform 
complex searches.  This is a very useful feature for QA-related activities. 

Regular Expression: A regular expression is a search string that contains 
special characters with specific meanings that allow you to provide a 
concise and flexible means to identify patterns of characters and words. 
The grammar of regular expressions follows industry standards. This is 
one of ApSIC Xbench search and QA modes. 

Microsoft Word Wildcard: ApSIC Xbench also allows you to perform 
searches using Microsoft Word wildcards, which follow a grammar 
similar to regular expressions but normally in a simplified alternative 
syntax. 

  

 

Searching Terminology 
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Defining Search Projects 

The first step to use the powerful search features of ApSIC Xbench is to 
define the reference material for your project. To do so, add the relevant 
files and directories into your project by choosing Project->Properties 
or pressing F2. The Project Properties dialog appears as illustrated 
below. 

 

Click the Add button to add files to your project. 

Select the type of file that you will be adding to the ApSIC Xbench 
project: 

 

C H A P T E R  3  



 

16 Using ApSIC Xbench  

 

ApSIC Xbench supports the following file types: 

� Tab-delimited Text File (*.txt). A file where every line consists of a 
number of fields delimited with the tab character. The first and the 
second fields of an entry are assumed to be the source and the target 
texts respectively. The additional fields are assumed to be descriptive 
and there can be any number of them. 

� XLIFF File (*.xlf, *.xlif, *.xliff). A file compliant with the XLIFF 
specification. 

� TMX Memory (*.tmx). A file compliant with the TMX specification. 
Most translation tools are capable of generating TMX memories of 
varying compliance levels. 

� TBX/MARTIF Glossary (*.xml, *.tbx, *.mtf). A file compliant with the 
TBX or the MARTIF specification. 

� Trados Exported Memory (*.txt). A Trados memory in .txt format as 
exported from Trados. 

� Trados Exported MultiTerm 5 Glossary (*.txt). A Multiterm glossary 
exported into a .txt file where each entry is delimited with a line 
containing two asterisks (**). 

� Trados MultiTerm XML Glossary (*.xml). A Multiterm glossary 
exported in XML format. 

� Trados TagEditor File (*.ttx). A Trados .ttx file. 

� Trados Word File (*.doc, *.rtf). A Trados .doc or *.rtf file with bilingual 
segments. 

� Trados Studio File (*.sdlxliff, *.sdlproj). A Trados Studio *.sdlxliff or 
*.sdlproj file. When a Trados Studio project file (*.project) is 
specified, ApSIC Xbench opens the sdlxilff files pointed by the 
project file for the first language pair found in the project file. 

� SDLX File (*.itd). A SDLX .itd file. Note: This option requires that 
SDLX is installed on the machine.  

� SDLX Memory (*.mdb). An individual SDLX .mdb file containing a 
translation memory. 

� STAR Transit 2.6/XV Directory Tree. A directory that contains the 
Transit file pairs. Please note that ApSIC Xbench does not support 
STAR Transit NXT file pairs. 

� PO File. A bilingual .po file, normally generated with gettext. 

� IBM TM/OpenTM2 Dictionary (*.sgm). An IBM TranslationManager or 
OpenTM2 dictionary in SGML format. This file has the .sgm 
extension. 

� IBM TM/OpenTM2 Folder. An IBM TranslationManager or OpenTM2 
folder installed on your system. This format can be defined as 
ongoing translation to clearly distinguish the new and the old 
translation and also to display the untranslated segments to make 
better decisions for new terminology. 

� IBM TM/OpenTM2 Exported Folder (*.fxp). An IBM 
TranslationManager or OpenTM2 folder exported in .fxp format. 

� IBM TM/OpenTM2 Exported Memory (*.exp). An IBM 
TranslationManager or OpenTM2 memory exported in .exp format. 
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� Wordfast Memory (*.txt). A Wordfast memory, with the .txt extension. 

� Wordfast Glossary (*txt). A Wordfast glossary, with the .txt extension. 

� Wordfast Pro TXML (*.txml). A Wordfast Pro bilingual file, with the 
*.txml extension. 

� DejaVu X/Idiom File (*.wsprj, *.dvprj). A DejaVu or Idiom database of 
project translation files, with extensions .dvprj or .wsprj. 

� DejaVu X/Idiom Memory (*.wstm, *.dvmdb). A DejaVu or Idiom 
translation memory, with extensions .dvmdb or .wstm. 

� Logoport RTF (*.rtf). An individual logoport .rtf file or a directory 
containing Logoport .rtf files. 

� Microsoft Glossary (*.csv). A Microsoft software glossary, made 
publicly available by Microsoft via MSDN and containing all the 
strings of a Microsoft software application. 

� Mac OS X Glossary (*.ad). A file in Apple's XML format for software, 
freely downloadable from the Internet. 

� Remote Xbench Server. A reference to a Remote ApSIC Xbench 
Server. 

After the file type is selected, the File List tab appears where you can add 
multiple entries of the selected type.  Depending on the file type chosen, 
click on the Add File... or Add Folder... button to add entries to the list. 

From this point, the sequence of displays may differ depending on the 
selected file type. Follow the instructions corresponding to the specific 
file type for the exact steps. 

 

If you are adding a ... Follow these steps: 

Tab-delimited text file, XLIFF 
file, TMX memory, Trados 
Exported memory, Trados Tag 
Editor file, Trados Word file, 
Trados Studio file, SDLX file, 
SDLX Memory, PO file, IBM 
TM/OpenTM2 Dictionary, 
IBM TM/OpenTM2 Exported 
folder, IBM TM/OpenTM2 
Exported memory, Wordfast 
memory, Wordfast glossary, 
Wordfast Pro TXML, 
Microsoft glossary, Mac OS X 
glossary, Deja Vu X/Idiom 
file, Deja Vu/Idiom Memory, 
Logoport RTF file 

1 The File List tab appears. Click 
Add Filer or Add Folder to add 
files or folders of files from the 
selected type. Folders will appear 
on boldface in the list. 

2 Click Next on the File List tab to 
get to the Properties tab. 

3 Assign the properties relevant and 
click OK to finish. Note: If you 
added any folder in step 1, click 
Next to get to an additional panel 
where you indicate if you wish to 
include files of the same type in 
child folders with the Recurse 
Directories check box. 
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STAR Transit directory tree 1 After the File List tab appears, 
opening automatically the Select 
Directory.. dialog. Navigate to the 
directory that contains the files you 
wish to load into the ApSIC 
Xbench project. 

2 Click Next on the File List tab to 
get to the Properties tab. 

3 Assign the properties relevant to 
the directory tree and click Next to 
get to the Directory Settings tab. 

4 In the Directory Settings tab you 
can check the Recurse Directories 
checkbox to have ApSIC Xbench 
search also subdirectories for files. 

Trados exported MultiTerm 5 
glossary, Trados MultiTerm 
XML, or TBX/MARTIF 

1 The File List tab appears, opening 
automatically the Add Glossary 
dialog. Select all the files of the 
current type in this window.  If you 
need to pick up more files from 
another directory, when you are 
again in the File List tab, click the 
Add File button to open again the 
Add Glossary window. 

2 Click Next on the File List tab to 
get to the Properties tab. 

3 Assign the properties relevant to 
the file and click Next to get to the 
tab corresponding to the file 
format. 

4 Select the source and the target 
language from the list of languages 
offered and click OK to finish. 

IBM TM/OpenTM2 Folder 1 After the File List tab appears, 
opening automatically the Select 
IBM TM/OpenTM2 Folder 
dialog. If necessary, change to the 
drive containing your IBM TM or 
OpenTM2 folder and then select 
the folder or folders in the list of 
folders that appears. 

2 Click Next on the File List tab to 
get to the Properties tab. 

3 Assign the properties relevant and 
click OK to finish. 
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Remote Xbench Server 1 Assign the properties relevant and 
click Next to get to the Remote 
Xbench Server tab. 

2 Assign a name for the connection 
and specify the URL of the Xbench 
Server. 

Once you are returned to the Project Properties window, you can add 
other files or directories following the steps described above. 

When you are done, click OK on the Project Properties window to 
return to ApSIC Xbench main window. ApSIC Xbench will load the 
glossaries into the work environment. 

At this time, on the Project menu, click Save as to save the newly 
created glossary definition in your directory with other ApSIC Xbench 
projects. It is recommended to save project files with meaningful names 
for later reuse.  

Note: The next time ApSIC Xbench is started, it will automatically load 
the previous project unless this feature is disabled in Tools->Settings-
>Miscellaneous Settings. 
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Searching for Terms 

ApSIC Xbench has a very powerful search engine. For example, you can 
search by source term, target term, or both source and target term. ApSIC 
Xbench also allows you to search using regular expressions or Microsoft 
Word wildcards, and combine them using the PowerSearch mode. 

 

Likely, most of your searches will be done by source term. However, 
your need to search for a term will not originate while you are in the 
interface of ApSIC Xbench, but when you are translating within Word or 
within some other CAT application such as Trados Translator’s 
Workbench, SDLX, IBM TranslationManager, Déjà Vu, or from a note in 
your e-mail program such as Microsoft Outlook or Firebird. 

This is why ApSIC Xbench is accessible system-wide from any 
application with a single key combination (Ctrl+Alt+Ins). 

The following 5 steps describe how you should interact with ApSIC 
Xbench. The starting point for this scenario is an open document with 
Microsoft Word in the foreground and an ApSIC Xbench project loaded 
in the background. 

1 In Microsoft Word, highlight the term (totally or partially) that you 
want to search for.  
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2 In Microsoft Word, press Ctrl+Alt+Ins to call ApSIC Xbench. This 
action automatically searches the files loaded into ApSIC Xbench for 
the marked term. This sequence of keys will be the most important 
one for you when using ApSIC Xbench.  

3 ApSIC Xbench presents the results of the query as illustrated in the 
figure above. 

You can have up to three priority areas, one in green (high priority), 
one in maroon (medium priority), and one in blue (low priority). The 
column labeled # provides a count of all the occurrences in the file 
that have been grouped for the entry shown on the window. 

The green bullet  next to the Target term indicates that the entry is a 
full exact match (case sensitive) with the search string. If a yellow 
bullet  appears next to a Target term, it means that the entry is a full 
match except for the case. For example, if in the above example we 
had searched for “Clipboard” instead of “clipboard”, the bullets 
would have been green instead of yellow because the case of the 
query string would match exactly the case of the string that is found 
in the file (Clipboard). 

When translating documentation, this indication is very useful 
because you can copy-and-paste the target term, which makes you 
more productive and accurate. The following steps describe how to 
benefit from this. 

4 If you want to copy the target term of the currently selected entry into 
the clipboard, just press Enter to close the ApSIC Xbench window. 
ApSIC Xbench is hidden and you are returned to the calling 
application (in this example, Microsoft Word). 

Note: If you do not want to copy anything to the clipboard, press Esc 
or Alt+F4 to hide ApSIC Xbench and return to Microsoft Word. 

5 If you opted to close the ApSIC Xbench window with the Enter key, 
thus saving the target term in the clipboard, you can press Shift+Ins to 
copy the target term into your document. 

You will notice that, especially for software options, it is faster to search 
and paste than to type the target software options manually. Thus, you are 
more productive and your translations are more consistent at the same 
time. 

Tip: Familiarize yourself with the above procedure until you feel it is 
intuitive enough. Try it with words that you know are exact matches so 
you can get familiar with the paste step. 
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Regular Expressions and 
Microsoft Word Wildcards 

ApSIC Xbench allows you to perform powerful searches using regular 
expressions or Microsoft Word wildcards.  To activate these search 
modes, do the following: 

1. Choose View->Search Options to show the Search Options pane. 

2. Expand the Search Mode drop-down and choose Regular 
Expressions or MS Word Wildcards 

3. You will notice that an icon will appear next to the Source Term and 
Target Term fields to indicate that you are in the selected mode. 

Regular Expressions Syntax 

Character or 
Expression 

Meaning Examples 

. Any character Jo.n matches John and Joan, but does not 
match Johan. 

* 0 or more instances of the 
preceding character 

Joh*n matches Jon, John, and Johhn, but does 
not match Johan. 

Note: In Regular Expressions, the asterisk does 
not have the same behaviour as in Microsoft 
Word wildcards. To mean any number of 
characters you need to use the dot-asterisk 
sequence (.*). For example, Joh.*n matches 
John, Johhn, and Johan (but does not match 
Jon). 

? 0 or 1 instances of the preceding 
character 

Joh?n matches Jon and John, but does not 
match Johan. 

+ 1 or more repetitions of the 
preceding character 

Joh+n matches John, and Johhn, but does not 
match Jon or Johan. 

{m} Exactly m repetitions of the 
preceding character 

Joh{2}n matches Johhn, but does not match 
Jon, John or Johhhn. 

{m,} m or more repetitions of the 
preceding character 

Joh{2,}n matches Johhn and Johhhn, but does 
not match Jon or John. 
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{,n} 1 to n repetitions of the 
preceding character 

Joh{,2}n matches John and Johhn, but does 
not match Jon or Johhhn. 

{m,n} m to n repetitions of the 
preceding character 

Joh{1,2}n matches John and Johhn, but does 
not match Jon or Johhhn. 

< Start of word <Phon matches Phone but does not match 
iPhone. 

> End of word hones> matches Phones but does not match 
Phone. 

Note: To match a whole word, you can specify 
<Phone> to match Phone, but not Phones or 
iPhone, or you can specify <Phones*> to 
match both Phone and Phones, but not iPhone 
or iPhones. 

^ Start of line (needs to be at the 
beginning of the expression) 

^Phone will match all units that start with 
Phone. 

$ End of line (needs to be at the 
end of the expression) 

received$ will match all units that end with 
received. 

\ Escape character.  The character 
following it is parsed as a simple 
character. 

phone\. will match all units that have a period 
after phone. (In this case, the dot does not mean 
"any character" because it is escaped). 

% Make the preceding character or 
expression case-insensitive.  
When ApSIC Xbench search 
mode is case-sensitive, this 
modifier can be used to make 
part of the search string case-
insensitive. 

In ApSIC Xbench case-sensitive mode, a% will 
match a and A. Similarly, P(hone)% will match 
Phone and PHONE, but will not match phone 
because in the latter case, the letter p is not 
included in the expression affected by the 
modifier. 

\xnn The character specified by nn, 
where nn is an hexadecimal 
number. 

\x48\x6f\x77\x64\x79\x3f matches Howdy? 

| OR operator ^H|I matches all sentences that start with an H 
or that start with an I. 

( ) Parenthesis operator to specify 
priority 

(^H)|I matches all sentences that start with an 
H or that contain an I. 
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[set-expression] One character belonging to the 
set defined by set-expression. A 
set is defined by individual 
characters (for example, 
[aeiou]) and/or by ranges of 
characters specified by the 
starting and the ending character 
(for example, [a-z]). 

File[0-9] matches File0, File1, File2, ... File9, 
but does not match FileX. 

File[ABC] matches FileA, FileB and FileC, but 
does not match FileD. 

[:special-set:] One character belonging to a 
pre-defined special-set. The 
following special sets are pre-
defined In ApSIC Xbench: 
[:space:], [:control:], 
[:punctuation:], [:punct:], 
[:separator:], [:sep:], [:symbol:], 
[:alpha:], [:num:], [:xdigit:], 
[:alphanum:], [:letter:], [:digit:], 
[:letterdigit:], [:number:]. 
Special set must be used within 
set-expressions (for example 
[:digit:]). The characters 
matched by each special-set are 
listed in Special Sets (on page 
29). 

File[:digit:] matches File0, File1 or File2, but 
does not match FileA or FileB. 

File[:alpha:][:digit:] matches FileA0, FileB1 
or FileC2, but does not match File1A or File2B. 

[^set-
expression] 

Any character not belonging to 
the set-expression. 

File[^ABC] matches FileD or FileE, but does 
not match FileA, FileB and FileC. 

(expression)=n Assigns to variable n the 
resolved value of the expression 
in the currently parsed segment.  
The resolved value can be 
recalled with the expression @n. 

(File[0-9])=1 defines variable 1 as the resolved 
value of File[0-9]. 

@n Renders the resolved value of 
variable n. 

@1 in the example above would resolve to 
string File1 if the string searched contains File1, 
File2 if it contains File2, and so on. 
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Microsoft Word Wildcards Syntax 

Character or 
Expression 

Meaning Examples 

. Any character Jo.n matches John and Joan, but does not 
match Johan. 

* 0 or more characters Joh*n matches John, Johan and Johhn, but 
does not match Jon. 

? 0 or 1 characters Jo?n matches Jon, John and Joan, but does 
not match Johan. 

@ 1 or more repetitions of the 
preceding character 

Joh@n matches John, and Johhn, but does not 
match Jon or Johan. 

{m} Exactly m repetitions of the 
preceding character 

Joh{2}n matches Johhn, but does not match 
Jon, John or Johhhn. 

{m,} m or more repetitions of the 
preceding character 

Joh{2,}n matches Johhn and Johhhn, but does 
not match Jon or John. 

{,n} 1 to n repetitions of the 
preceding character 

Joh{,2}n matches John and Johhn, but does 
not match Jon or Johhhn. 

{m,n} m to n repetitions of the 
preceding character 

Joh{1,2}n matches John and Johhn, but does 
not match Jon or Johhhn. 

< Start of word <Phon matches Phone but does not match 
iPhone. 

> End of word hones> matches Phones but does not match 
Phone. 

Note: To match a whole word, you can specify 
<Phone> to match Phone, but not Phones or 
iPhone, or you can specify <Phones*> to 
match both Phone and Phones, but not iPhone 
or iPhones. 

^ Start of line (needs to be at the 
beginning of the expression) 

^Phone will match all units that start with 
Phone. 

$ End of line (needs to be at the 
end of the expression) 

received$ will match all units that end with 
received. 

\ Escape character.  The character 
following it is parsed as a simple 
character. 

phone\. will match all units that have a period 
after phone. (In this case, the dot does not mean 
"any character" because it is escaped). 
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\xnn The character specified by nn, 
where nn is an hexadecimal 
number. 

\x48\x6f\x77\x64\x79\x3f matches Howdy? 

| OR operator ^H|I matches all sentences that start with an H 
or that start with an I. 

( ) Parenthesis operator to specify 
priority 

(^H)|I matches all sentences that start with an 
H or that contain an I. 

[set-expression] One character belonging to the 
set defined by set-expression. A 
set is defined by individual 
characters (for example, [aeiou]) 
and/or by ranges of characters 
specified by the starting and the 
ending character (for example, 
[a-z]). 

File[0-9] matches File0, File1, File2, ... File9, 
but does not match FileX. 

File[ABC] matches FileA, FileB and FileC, but 
does not match FileD. 

[:special-set:] One character belonging to a pre-
defined special-set. The 
following special sets are pre-
defined In ApSIC Xbench: 
[:space:], [:control:], 
[:punctuation:], [:punct:], 
[:separator:], [:sep:], [:symbol:], 
[:alpha:], [:num:], [:xdigit:], 
[:alphanum:], [:letter:], [:digit:], 
[:letterdigit:], [:number:]. Special 
set must be used within set-
expressions (for example 
[:digit:]). The characters matched 
by each special-set are listed in 
Special Sets (on page 29). 

File[:digit:] matches File0, File1 or File2, but 
does not match FileA or FileB. 

File[:alpha:][:digit:] matches FileA0, FileB1 
or FileC2, but does not match File1A or 
File2B. 

[!set-
expression] 

Any character not belonging to 
the set-expression. 

File[!ABC] matches FileD or FileE, but does 
not match FileA, FileB and FileC. 

(expression)=n Assigns to variable n the 
resolved value of the expression 
in the currently parsed segment.  
The resolved value can be 
recalled with the expression \n. 

(File[0-9])=1 defines variable 1 as the resolved 
value of File[0-9]. 

\n Renders the resolved value of 
variable n. 

\1 in the example above would resolve to string 
File1 if the string searched contains File1, File2 
if it contains File2, and so on. 
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Special Sets 

The following table shows the characters that are matched by the special 
sets that can be used in regular expressions and Microsoft Word wildcard 
characters: 

Special Set Characters matched by the special set 

[:alpha:] Any of the characters considered as alphabetic by 
the operating system under the current ANSI 
code page. 

[:alphanum:] Any of the characters considered as alphanumeric 
by the operating system under the current ANSI 
code page. 

[:control:] Characters in the hexadecimal range 0x00-0x19. 

[:digit:] Any digit from '0' to '9'. 

[:letter:] Synonym for [:alpha:]. 

[:letterdigit:] Synonym for [:alphanumeric:]. 

[:num:], [:number:] Any digit from '0' to '9' and the following 
superscript and fractional numbers: '¹', '²', '³', '¼', 
'½', '¾' 

[:punct:], 
[:punctuation:] 

Any of the following characters: ! " # % & ' ( ) * , 
- . / : ; ? @ [ \ ] _ { } ¡ « - · » ¿ 

[:sep:], [:separator:] Space (Hex 0x20) and non-breakable space (Hex 
0xA0) 

[:symbol:] Any of the following characters: $ + <=> ^ ` | ~ ¢ 
£ ¤ ¥ ¦ § ¨ © ¬ ® ‾ ° ± ´ ¶ ¸ × ÷ 

[:space:] Space (Hex 0x20), tabs and carriage returns in 
the range Hex 0x09-0x0C, plus Hex 0x85 and 
Hex 0xA0. 

[:xdigit:] Any hexadecimal digit from '0' to '9' and from 'a' 
to 'f' (or 'A' to 'F'). 
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Advanced Features 

ApSIC Xbench has some advanced features that you will appreciate when 
you have special needs. They are described in the following sections. 

PowerSearch function 

You can use the Ctrl+P (PowerSearch) key combination to search with 
more complex criteria.  With the PowerSearch function you can search 
for entries:  

� That contain two or more strings, but not necessarily next to each 
other. 

� That do not contain a given string. 

� That contain a string or another string. 

� Any combination of the above conditions. 

Examples: 

This expression... ...does the following 

string1 string2 It finds all entries that contain "string1" and 
"string2" 

string1 or string2 It finds all entries that contain "string1" or 
"string2" 

string1 -string2 It finds all entries that contain "string1" but 
do not contain "string2" 

string1 -"string2 with 
embedded blanks" 

It finds all entries that contain string1 but do 
not contain "string2 with embedded blanks" 

In more complex expressions involving several strings with Boolean 
and/or relationships, you can use parenthesis to indicate precedence. 

In PowerSearch mode, you need to use double quotes as delimiters if 
your expression contains embedded blanks or parenthesis. If your search 
string contains a double quote character embedded, you need to escape it 
using a sequence of two double quote characters. 

Note: If one of the words to search in PowerSearch mode is the word 
"or", you need to enclose the word "or" in double quotes to avoid that it is 
parsed as the or operator. 
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PowerSearch can be used in any of the searching modes: Simple, 
Regular Expressions, and MS Word Wildcards. 

Zooming In 

ApSIC Xbench features 3 types of zoom: 

� Zoom to Level 

� Zoom to Glossary 

� Zoom to File 

As you already noticed, ApSIC Xbench shows a snapshot of the most 
relevant terms for each priority level on a single unified view. This allows 
you to analyze the sources of potential inconsistencies or even different 
meanings and make a more informed decision on which term to choose. 

However, it is possible that you want to see more (or all) instances of a 
specific level to make a more thorough analysis of a specific term. 

To do so, double-click the body of the window for the level that you want 
to zoom in to obtain a full list of entries for the searched term. The 
background will become green so that you can tell that you are in zoomed 
mode. 

To exit the zoomed mode, double-click the body of the window again. 

Reverse search 

ApSIC Xbench also defines a system-wide key for searching in the target 
column instead of in the source column. The default key combination for 
this feature is Ctrl+Alt+Backspace. 

This is equivalent to leaving the Source Term field blank and the Target 
Term field filled out. 

For example, this is convenient when you want to use a new term in your 
language and want to make sure that such a term is not already used in 
another term that could create potential clashes in the future with key 
terminology for your project. 
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Searching only in ongoing 
translation 

In the Search Options pane, you can check the Only Ongoing 
Translation check box to limit the search to only the files defined as 
ongoing translation.  This is useful when you add your current translation 
to the ApSIC Xbench project and wish to carry out a global search and 
replace only in your ongoing translation. 

Searching only in new 
segments 

In the Search Options pane, you can check the Only New Segments 
check box to limit the search to only those segments whose status is New.  
This is useful when you need to perform global searches and replace for 
only the part of your translation that is new, skipping 100% matches. 

Excluding ICE (In-Context 
Exact matches) segments 
from search results 

In the Search Options pane, you can check the Exclude ICE Segments 
check box to exclude from the search those segments whose status is ICE.  
This is useful when you need to focus in segments that are not exact 
context matches. 

Seeing the context 

If you right-click on a search result and choose the See Context menu 
item, the ten units that are found in the file physically before and after the 
current entry appear. 
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Editing the source 

The Tools->Edit Source menu item, also attached to the Ctrl+Alt+Enter 
or Ctrl+E key combination, allows you to open the source file to which 
the entry currently selected belongs.  This is very useful to quickly amend 
a terminology error detected in an ongoing translation. When the source 
file is a SDLX itd file, a Trados Tag Editor ttx file, a Trados Word file, or 
an IBM Translation Manager folder, ApSIC Xbench goes directly to the 
segment that contains the text.   

To use this feature with IBM Translation Manager, please be sure that 
IBM Translation Manager is up and running and that there is no 
document currently being edited. 

Line positioning is also available for Tab-delimited files and Trados 
exported memories, but your text editor parameters must be configured in 
Tools->Settings->Text Editor. For example, to configure TextPad 4 for 
line positioning, you must select there the Text Pad executable and 
specify the following in Command-Line Parameters: 
$filename($line,$column). Similarly, to configure Notepad++, you must 
select its executable and specify the following in Command-Line 
Parameters: $filename -n$line. Other text editors will require different 
values for this field. Please check your text editor's documentation for the 
suitable values. 

ApSIC Xbench also allows to perform segment positioning for the TMX 
format, but the TMX editor must be configured in Tools->Settings-
>TMX Editor. For example, to configure OKAPI Olifant for segment 
positioning, you must select there the Olifant executable and specify the 
following in Command-Line Parameters: $Filename row=$Segment 
col=trg edit=yes. Other TMX editors might have different values for this 
field. Please check your TMX editor's documentation for the suitable 
values.  

This makes ApSIC Xbench a very useful and efficient tool to make 
global changes in terminology for these formats. If you afterwards want 
to regress the changes made, you can reload the ApSIC Xbench project 
with Project->Reload or View->Refresh. 
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Search templates 

Search templates are pre-defined searches that you can choose or run. To 
use a search template, click on Search Templates... on the Search 
Options pane and then choose the search from the list. In Template 
Source, you can choose to show the Sample Search Templates or the 
Project Checklist entries.  Click Search to run directly the search 
currently selected or click Choose to bring up the search template 
definition to the Source Term and Target Term fields. 
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Exporting Items 

ApSIC Xbench allows you to export the project items in the following 
formats: 

� TMX files 

� Tab-delimited text files 

To export the contents of a project choose Tools->Export Items.  The 
following dialog appears: 

 

In this dialog, you can export all items in a project, all items in the current 
query, only the items displayed in the current query (for example, if you 
are in overview mode, you only see a few items from each priority level), 
or all the items of a glossary that is a member of the project. 

If you wish, you can remove the repetitions (items that have exactly the 
same source and target values) from the exported data to reduce the size 
of the resulting file. You can also exclude the ICE (In-Context Exact 
matches) segments from the search. 

Additionally, you can limit the export to only untranslated items (for 
example to facilitate the feed to a machine translation system) or to only 
translated items.  If you choose to export only the translated items, you 
can further specify if you wish to export only the pretranslated items (that 
is, items retrieved from a translation memory) or newly translated items. 

When exporting a tab-delimited text file, a header row can be added.   
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When exporting a TMX file, the source and target locales can be 
specified. You can specify any value in these fields. If you don't 
remember the locale code, you can press the ellipsis (...) button to open a 
helper window to enter the languages and countries.   

 

If you normally work with a limited set of files, you can click the arrow 
button of the combo box to open a shorter language list of recently used 
selections. 
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Working with Ongoing 
Translations 

ApSIC Xbench allows you to define any file as ongoing translation in the 
Project Properties window. 

By default, when they are added to an ApSIC Xbench project, the 
following file types are defined as ongoing translation: 

� XLIFF 

� Trados TagEditor 

� Trados Word 

� Trados Studio 

� SDLX. Note: This option requires that SDLX is installed on the 
machine.  

� STAR Transit 2.6/XV 

� PO 

� IBM TM Folders 

� OpenTM2 Folders 

� Wordfast TXML 

� Déjà Vu/Idiom 

� Logoport RTF 

When a file or directory is defined as ongoing translation, the following 
two features are enabled: 

� Translations identified as new (not 100% matches) are flagged with a 
small red dot ( ). Translations that are 100% matches in the ongoing 
translation are flagged with a hollow red dot ( ). These symbols allow 
you to tell if the term was introduced by you or was already in the 
existing memory.  This helps you to make terminology-related 
decisions, for example if you wish to recap on the translation for a 
term and you want to make sure that the term was not already used in 
the official translation memory used to pretranslate your project. 

� Untranslated segments appear after the translated segments.  This is 
especially useful to decide which terminology to use for a new term 
by seeing how it will appear in all the future instances in your own 
translation.  This way you can make sure that the term chosen will be 
a good match for all instances in your current translation. 

Note: Glossaries defined as ongoing translation (normally only one per 
project, but can be more) appear in bold face in the Project Properties 
window. 
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In addition, files defined as ongoing translation can be parsed by ApSIC 
Xbench powerful QA functions. 
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Key Terms 

ApSIC Xbench allows you to define one or more files as Key Terms. To 
do so, when in the list of glossaries in Project Properties, choose the 
Key Terms check box.  A green star will appear next to the glossary 
entry as shown in the illustration below to indicate that the glossary 
belongs to the Key Terms category. 

 

When a file is defined as Key Term, its entries appear with a star on top 
of the results. The color of the star indicates if the key term is an exact 

match (green star ), an exact match except for the case (yellow star ), 
or if the text searched is contained in the key term entry (empty star ). 

The example below shows entries "clipboard" and "Clipboard Viewer", 
which are flagged as Key Terms: 
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In the example above, the green solid star for the "clipboard" entry means 
that the entry is a full match. The empty star in the "Clipboard viewer" 
entry means that the searched term is part of a key term. 

The QA feature also makes use of Key Terms defined for the project by 
checking if they have been used in the ongoing translation. 
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ApSIC Xbench features Quality Assurance (QA) functions to perform 
advanced checks on the files defined as ongoing translation.  The QA 
functions try to find segments with the following potential problems: 

� Untranslated segments 

� Segments that have the same source text but a different target text 

� Segments that have the same target text but a different source text 

� Segments where the target text matches the source text 

� Segments with tag mismatches 

� Segments with number mismatches 

� Segments with double blanks 

� Segments that deviate from the key terms of the project 

� Segments that meet the search criteria of items in the Project or 
Personal Checklists. See Managing Checklists for more information 
about this feature. 

  

The Quality Assurance functions are carried out with the QA tab in the 
main window.  The QA tab can perform the following functions: 

Perform all checks selected in Check Group and List of Checks by 
clicking Check Ongoing Translation.  By default all available checks 
are selected, except Target same as Source. 

� Perform only the searches defined by the Project Checklists by 
clicking on Run Project Checklists. 

� Perform only the searches defined by the current Personal Checklists 
by clicking on Run Personal Checklists. To change the current 
Personal Checklists, choose Tools->Manage Checklists. 

� Export the displayed QA results by right-clicking and choose Export 
QA Results to the following formats: HTML, tab-delimited text, 
Excel, or XML. 

Working with Quality Assurance 
Features 
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Note: Please remember that the ApSIC Xbench license does not permit 
removal of the credits on the right-hand side at the beginning of the 
exported QA report.  We have tried to make this credit information non-
intrusive and its aim is to avoid tell-a-friend or other more intrusive ways 
of promoting use of the product among peers.  

Results are shown in the body window of the QA tab. For some file 
formats, you can open directly from ApSIC Xbench the file at the segment 
shown to correct it by selecting Tools->Edit Source or by pressing 
Ctrl+E. 

You can limit the scope of the strings considered by the QA process by 
checking the Only New Segments or Exclude ICE Segments check 
boxes.  

You can also make the consistency check mode case-sensitive by 
checking the Case-sensitive Inconsistencies check box. 

You can ignore the tag content within the segments for the QA pass by 
choosing Ignore Tags. This will allow you to find inconsistencies that 
have the same source or target text except for inline tags. 

This window allows you to mark an issue by right-clicking on it and 
choosing Mark/Unmark Issue.  You can then optionally show or hide 
marked issues with the Show Marked or Hide Marked radio buttons 
under Filter Issues in order to limit the number of issues displayed. Note: 
The Export QA Results command only exports displayed issues (it does 
not export hidden issues). 

 



 

 45 

 

Managing Checklists 

Checklists are a very useful Quality Assurance (QA) function in ApSIC 
Xbench. Built on ApSIC Xbench search engine, checklists are a 
compilation of searches that can be run in batch to identify segments with 
problems. Typically, you store in checklists common pitfalls, such as use 
of banned terms or expressions. It is a very good practice to compile 
client feedback in checklists to make sure that no feedback is forgotten in 
subsequent deliveries of translations. 

In the QA tab of the main Window, you will be able to run these 
checklist against all files defined as ongoing translation in the ApSIC 
Xbench project. 

Since checklists are built on top of ApSIC Xbench search engine, 
anything that can be searched for in ApSIC Xbench can be added to a 
checklist. Actually, one useful means of adding a search into the checklist 
is by searching it first in the Project tab, and then clicking Add Last 
Search to Checklist in the Search Options pane of the main window. 

There are two types of checklists: the Project Checklist and the Personal 
Checklist. 

The Project Checklist is saved with the ApSIC Xbench project file (.xbp 
extension) and normally it contains checks that are specific of the project, 
such as checking if some untranslatable keywords have been accidentally 
translated.   

The Personal Checklists are not saved to the ApSIC Xbench project file. 
Instead they are saved to an ApSIC Xbench checklist file (.xbckl 
extension). ApSIC Xbench remembers the last set of personal checklists 
used across projects.  You can have any number of personal checklists 
loaded at any given time. Personal checklists normally contain non-
project types of checks, such as a common misspelling that survives the 
spell checker or a generic language rule that is interesting to check across 
projects.  They are called "personal" because the terms compiled in this 
lists normally are filled with the errors that a given translator is more 
prone to do. 

Checklists are managed in the Checklist Management dialog. You can 
reach the Checklist Management dialog with the following methods: 

� Choose Tools->Manage Checklists. 

� Click the Manage Checklists icon on the tool bar. 

The Checklist Management dialog allows you to work with your Project 
and Personal Checklists. 
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In the Checklist Management dialog, you can create new Personal 
Checklists by choosing Checklist->New when the cursor is placed on 
Personal Checklists group in the navigation tree. You can also add an 
existing checklist with Checklist->Add. All of the personal checklists 
listed under Personal Checklists will be run when you click Run 
Personal Checklists or Check Ongoing Translation on the QA tab. 

The <Project> checklist is stored in the ApSIC Xbench project file (.xbp 
extension), and cannot be removed from the Project Checklists group in 
the navigation tree.  You can add more checklists to the Project 
Checklists group, which will be run when you click Run Project 
Checklists or Check Ongoing Translation on the QA tab.  The items in 
these additional project checklists are not saved to the ApSIC Xbench 
project file itself but they become liked to the project, so next time you 
open the ApSIC Xbench project file, any checklists linked to it will also 
appear here. 

The items of the checklist selected on the navigation tree are shown on 
the body of the window. You can sort by any of the columns.  If you wish 
to disable an individual item in a checklist you can uncheck its check 
box.  
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Please note that the unchecked state is saved to disk if you save the 
checklist, so next time that you open the same checklist the item will 
remain unchecked. 

When you click on a column heading, the list is sorted by that column 
alphabetically. If you click on the column heading a second a second 
time, the list is sorted from bottom to top. If you type a sequence of 
characters, the current column will be searched for the typed sequence of 
characters. 

Individual checklist items can be added or edited. Fields available are the 
same that can be specified in the Search Options pane of the Project tab. 

 

In addition, you can also specify a category for the checklist entry in the 
Category combo box. You can specify here any category name. If you 
wish to use a previously defined category name, you can expand the 
combo box by clicking the arrow button and choose it from the list. If you 
have created category names, you will be able to run selectively subsets 
of categories when you run a project or personal checklist from the QA 
tab using the Run Project Checklists or Run Personal Checklists 
buttons. 

You can also define inheritance relationships between checklists. When a 
checklist inherits from another one, all entries are inherited. You can 
inherit from several checklists. 

To inherit a checklist, do the following. 

1. Choose Edit->Inheritance->Add->Local (or click the Inheritance 
button and then right-click on the list of inherited items that appears and 
choose Add->Local). 

2. Type a name for the inherited checklist and choose the file name that 
contains it. The name specified here does not need to match the checklist 
display name. 
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3. Add any required checklists following steps 1 and 2. The dialog will 

show the inherited items with the  icon. You can override these 
inherited items but not edit or delete them. 

 

Once you set an inheritance relationship, any changes or additions you 
make in the parent checklist will be inherited. 

The Project Checklist is saved automatically when you save the project. 
If you add entries to the Project Checklist and shutdown ApSIC Xbench, 
you will be prompted to save the project. 

If you click Apply in this dialog, changes made to all checklists will be 
saved (except for the <Project> checklist that will be saved with the 
project file.  If you click OK, changes will be also saved and the window 
will close. 
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You will find here several topics that will provide you additional 
information on ApSIC Xbench features. 

 

Additional Information 
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Working with ApSIC 
Xbench Settings 

On the Tools menu, click Settings to open the Settings dialog as shown 
in the illustration below. 

 

In this dialog, you can set ApSIC Xbench to always start in maximized 
mode (recommended) and also change the default hot keys that are 
available system-wide. Note: Changing the default hot keys should be 
necessary only as a workaround to avoid clashing with any other 
application using the same keys. 

The fields in this dialog are: 

Maximize on Startup. If you check this box, ApSIC Xbench will appear 
maximized when it is launched.  It is recommended to check this box, as 
the maximized mode is the one that provides the maximum amount of 
information at the same time. 

Maximum Entries per Level in Overview Mode. The overview mode 
shows a few entries from each priority level. Specify here the maximum 
number of entries for a level.  If after searching you wish to see all 
matches whilst preserving the different levels of priority, you can press 
the blue Click here to show all matches link that appears under the 
results panel on the right side, or check the Show All Matches check box 
in the Search Options pane.  

C H A P T E R  1 2  



 

52 Using ApSIC Xbench  

 

The following settings belong to the Hotkeys group.  

Disable. This check box lets you disable the system-wide key 
combinations featured by ApSIC Xbench. It is recommended to leave 
this box unchecked as one of the most valuable features of ApSIC 
Xbench is the capability to search directly from any application. 

Source Hotkey. This is the hotkey defined to trigger a search of the 
clipboard contents in the source text. By default it is Ctrl+Alt+Ins. 

Target Hotkey. This is the hotkey defined to trigger a reverse search 
of the clipboard contents in the target text. By default it is 
Ctrl+Alt+Backspace. 

Automatic Substitution Hotkey. This is the hotkey defined to 
replace the target text automatically in the translation editor. This 
hotkey is intended to pickup translations automatically. The 
requirements for the automatic substitution are the following:  

� There must be an exact match of the term searched. 

� There must be one and only one variant of the term searched. 

If any of the two conditions above is not met, the behavior of this 
hotkey is the same one as the Source Hotkey. 

It is recommended not to change these hotkey settings unless they clash 
with the values in another application. 

Internet Hotkeys / Open in default browser.  When checked, it opens 
in your default browser the Internet query associated to the hot key (for 
example, Ctrl+Alt+1 or Ctrl+Alt+2), instead of opening it in ApSIC 
Xbench embedded browser.  For example, if you have the first configured 
entry of defined Internet links pointing to Google, you can use this 
feature to search the marked text directly in Google just by pressing 
Ctrl+Alt+1. 

Transfer Method. ApSIC Xbench uses the clipboard as a transfer 
mechanism between the different Windows applications and ApSIC 
Xbench. Normally the most convenient and consistent transfer method is 
to leave the default options Manual Copy and Manual Paste, but in some 
scenarios (for example with applications that do not feature standard copy 
and paste keystrokes), you may have to change these settings to get the 
most out of ApSIC Xbench. 

The options available as a transfer method for Input are: 

Copy Message. When you press Ctrl+Alt+Ins, ApSIC Xbench sends a 
COPY message to the application to copy the selected text into the 
clipboard and then performs a search using the contents of the 
clipboard. A limited number of applications support this technique, 
but it has the advantage of avoiding the need for copying manually 
the text into the clipboard (normally with Ctrl+Ins). 



 

 Chapter 12 53 

 
 

Manual Copy. In this mode, ApSIC Xbench expects that the user has 
already copied the text to search in the clipboard. It sounds more 
tedious, but it has the advantage that many applications support the 
Ctrl+Ins key combination for copying text, which means that you feel 
a more consistent behaviour across applications. On the downside, if 
the editing application has a slow response time, you may go too fast 
with the combination Ctrl+Ins, Crl+Alt+Ins for the application. 

Keyboard Emulation (Ctrl+Ins). In this mode, ApSIC Xbench 
sends the Ctrl+Ins keystroke to the editing application and then 
performs the search. This way the user needs not to type Ctrl+Ins 
manually prior to the search. Some applications may not support this 
input method. 

Keyboard Emulation (Ctrl+C). In this mode, ApSIC Xbench sends 
the Ctrl+C keystroke to the editing application and then performs the 
search. This way the user needs not to type Ctrl+C manually prior to 
the search. Some applications may not support this input method. 

The options available as a transfer method for Output and Automatic 
Substitution Output are: 

Paste Message. When your press Enter to select a translation, ApSIC 
Xbench sends a PASTE message to the application to paste the 
translation. A limited number of applications support this technique, 
but it has the advantage of avoiding the need for pasting manually the 
text into the clipboard (normally with Shift+Ins). 

Manual Paste. In this mode, ApSIC Xbench copies the target text of 
the selected entry into the clipboard if you press Enter to select a 
translation. The user is expected to press Shift+Ins (or the 
corresponding key combination for pasting text in the application). 
This is the default an recommended mode for consistency reasons 
across applications. 

Keyboard Emulation. In this mode, ApSIC Xbench sends the target 
text by simulating that it is entering the text to the editing application 
when you select an entry an press Enter to copy the selection into the 
clipboard. 

Keyboard Emulation (Ctrl+V). In this mode, ApSIC Xbench sends 
the target text by simulating the Ctrl+V keystroke to the editing 
application when you select an entry an press Enter to copy the 
selection into the clipboard. 
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Click the Colors tab of this dialog to change the default colors of the 
main window. The following window appears: 

 

Settings in this tab are the following. 

� Background color when zoomed. In ApSIC Xbench there are two 
modes: overview, with some entries from the priorities shown, and 
the zoomed mode, where all the entries of a given priority are shown. 
This is the background color that is used in zoomed mode, as an 
indicator that you are not in overview mode (the default mode is 
overview). 

� Key Terms priority. This is the color that will be used for entries 
that belong to the Key Terms priority. A glossary is defined as a Key 
Terms glossary in Project->Settings. 

� High Priority. This is the color that will be used for entries 
belonging to the high priority.  

� Medium Priority. This is the color that will be used for entries 
belonging to the medium priority. 

� Low Priority. This is the color that will be used for entries belonging 
to the low priority. 

� Background color when nothing found. This is the background 
color that appears in the search box when no entry is found. 
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Click the Internet tab to work with Internet definitions: 

 

The Internet tab lets you define the pattern URLs that you use to perform 
targeted searches in the Internet, for example in a dictionary.  You can 
have as many entries as you wish, but only the first 10 will have a hotkey 
assigned, either Alt+n within ApSIC Xbench or with Ctrl+Alt+n (with 
the numeric keypad in this latter case in Num Lock mode) from any 
Windows application. n can be a number from 0 to 9, where the 0 
corresponds to the 10th entry in the list. 

You can use the Up and Down buttons to move an entry up or down in 
the list. In ApSIC's website you can find a library of URLs ready to use. 

The up to 10 entries with a key assigned appear in the Internet menu. 

You can use Internet->Capture URL to capture URLs into this list. 
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The Miscellaneous Settings tab lets you specify if ApSIC Xbench should 
check weekly if there are updates to the program and also allows to 
enable the Alternative Project feature. 

 

Settings in this tab are the following: 

� Check weekly for new versions.  If this check box is enabled, 
ApSIC Xbench will check once a week if there are updates available. 

� Enable alternative project. If this check box is checked, ApSIC 
Xbench keeps in memory the project opened prior to the current one.  
To switch back and forth among both projects, choose Project-
>Switch to Alternative Project.  To discard the alternative project 
and recall the memory used by it, choose Projects->Forget 
Alternative Project. 

� Load last project when ApSIC Xbench starts. If this check box is 
checked, the next time ApSIC Xbench is started, it will load the 
project that was opened at the time of the last shut down. 

� Show warning when copying fuzzy match. If this check box is 
checked, ApSIC Xbench will issue a warning message if you press 
Enter to copy the entry currently selected in the search results and 
such entry does not match exactly the searched term. 

� Show warning when shutting down. If this check box is checked, 
ApSIC Xbench will issue a warning message when you shut it down. 

� Default Project Directory. This field allows you to specify the 
default folder for your ApSIC Xbench projects. 
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The Text Editor tab lets you configure command-line arguments for a 
text editor when using the Edit Source feature for search or QA results 
for a glossary in .txt format. This includes Tab-delimited Files, Trados 
Exported Memories, Wordfast Memories, and Wordfast Glossaries.  
When properly configured, this allows you to open the file directly at the 
line from which the segment selected with Edit Source comes from.  

 

If you choose to define a Text Editor, you need to assign values to the 
following fields: 

� Path to Executable. This is the path to the .exe file for the text 
Editor. You can use the button with the ellipsis (...) to navigate to the 
.exe file. 

� Command-line Parameters. These fields allows you to construct the 
command-line that should be passed to the editor. You can use 
several variables that will be replaced with values by ApSIC Xbench: 

� $Filename: The file name, including its path of the file. 

� $Line: The line number of the segment in the text file. This line 
refers to where the target text is located. 

� $Column: The column in the line where the target text is located. 

� $Segment: The segment number in the text file. 

For example, to configure TextPad 4 for line positioning, you must 
select there the Text Pad executable and specify the following in 
Command-Line Parameters: $filename($line,$column). Similarly, to 
configure Notepad++, you must select its executable and specify the 
following in Command-Line Parameters: $filename -n$line. Other 
text editors will require different values for this field. Please check 
your text editor's documentation for the suitable values. 
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The TMX Editor tab lets you configure command-line arguments for a 
TMX editor when using the Edit Source feature for search or QA results 
for a glossary in .tmx format. When properly configured, this allows you 
to open the file directly at the line from which the segment selected with 
Edit Source comes from.  

 

If you choose to define a TMX Editor, you need to assign values to the 
following fields: 

� Path to Executable. This is the path to the .exe file for the text 
Editor. You can use the button with the ellipsis (...) to navigate to the 
.exe file. 

� Command-line Parameters. These fields allows you to construct the 
command-line that should be passed to the editor. You can use 
several variables that will be replaced with values by ApSIC Xbench: 

� $Filename: The file name, including its path of the file. 

� $Line: The line number of the segment in the text file. This line 
refers to where the target text is located. 

� $Column: The column in the line where the target text is located. 

� $Segment: The segment number in the text file. 

For example, to configure OKAPI Olifant for segment positioning, 
you must select there the Olifant executable and specify the following 
in Command-Line Parameters: $Filename row=$Segment col=trg 
edit=yes. Other TMX editors might have different values for this 
field. Please check your TMX editor's documentation for the suitable 
values.  
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ApSIC Xbench Quick Tips 

This chapter focuses on the most important features of ApSIC Xbench 
and aims to be a quick view of what ApSIC Xbench can do. 

We strongly recommend to read this chapter to get the most out of ApSIC 
Xbench with the minimum learning effort. 

� ApSIC Xbench is not an indexer.  It reads the contents of the files 
each time you load a project and tries to respond to terminology 
queries very fast.  Therefore, loading all of the Microsoft glossaries 
for a major language can take several minutes and will require a 
significant amount of memory. If you plan to load huge amounts of 
reference in the range of tens of millions of words, it is strongly 
recommended to have at least 1 GB of memory.  If you don't have a 
very powerful machine, we do not recommend loading all Microsoft 
glossaries but a more focused selection with the subject areas that 
pertain to your current translation project. 

� Once loaded, ApSIC Xbench stays active in the background until it is 
explicitly shut down.  When ApSIC Xbench is active, a pink gem 
appears the system tray. To unload ApSIC Xbench from memory, 
you must shut it down.  For example, you can shut it down by right-
clicking on the icon in the system tray and then choosing Shutdown 
Xbench. 

� While ApSIC Xbench is active, it can be called from any Windows 
application with the Ctrl+Alt+Ins key sequence. If there is text marked 
in the application, ApSIC Xbench searches automatically the text 
marked. The actual keystrokes are configurable. 

� In addition to the Microsoft software glossaries, ApSIC Xbench 
supports many input formats from a number of CAT applications, 
including Trados, SDLX, Transit, Wordfast, IBM 
TranslationManager, and other industry-standard formats such as 
TMX, TBX, or XLIFF. You can combine the different formats into 
one Xbench Project by assigning priorities to each source to define the 
terminology decision process of your specific translation project. You 
can save each ApSIC Xbench project for later reuse. 

� You can copy the target text of the currently selected item into the 
clipboard by pressing Enter in the main window.  The Enter key 
closes the window copying the text so that it is ready for pasting in 
the application where you edit your translation using Shift+Insert. 
This is very useful when translating the documentation of a software 
application whose software strings are loaded into an ApSIC Xbench 
project. 

� QA checks can be run using the QA tab. QA checks are run only 
against glossaries defined as ongoing translation. A very powerful 
QA feature are checklists, which allow you to run in batch a number 
of predefined checks using the powerful ApSIC Xbench search 
capabilities. 
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After getting some familiarity with the basic capability of the product, we 
do encourage you to read the documentation with more detail to learn 
about many useful features that exist in the product. 
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Where to Obtain the 
Microsoft and Apple 
Software Glossaries 

Obtaining Microsoft 
Glossaries 

Although Microsoft software glossaries in .csv format were previously 
publicly available from Microsoft FTP site, at the time of this publication, 
they are only available though a MSDN subscription available for a fee. 

Each language has a separate .zip file that contains all the individual 
glossaries for the Microsoft products localized into that language. The 
size of each language file can range from 1 to more than 100 megabytes, 
which depends on the number of products that are localized by Microsoft 
into a particular language. 

Obtaining Apple 
Glossaries 

At the time of this publication, the Apple Mac OS X software glossaries 
are available from the following source: 

� http://developer.apple.com/internationalization/downloads/ 

The glossaries for each language are in Macintosh Disk Image format 
(extension .dmg). In order to load the Mac OS glossaries into ApSIC 
Xbench, the .ad files contained in this disk images must be extracted. To 
do so, you can use the UltraISO software 
http://www.ezbsystems.com/ultraiso/index.html. 
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ApSIC Xbench allows you to define Internet links that can be used to 
search the term in the Internet.  ApSIC Xbench features a simple 
embedded browser, but by pressing Ctrl+W, you can open your system 
default Internet browser at the page you are currently browsing in ApSIC 
Xbench. 

 

Internet 
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Searching the Internet 

ApSIC Xbench features an Internet tab that provides an integration path 
with some information and terminology sources available in the Internet. 
The following illustration shows a search in Google done within ApSIC 
Xbench. 

 

ApSIC Xbench has a few pre-defined shortcuts, but the user can change 
or define new links as required. Defined shortcuts are accessible using 
one of the following methods: 

Move to the Internet tab, select the desired source in the Website field, 
type the search string the Text to search field and press Enter. 

When ApSIC Xbench is the current application, press Alt+n, where n can 
be any number from 0 to 9. The 0 corresponds to the 10th entry in the list. 
The current term in the Source field of the Project tab or in the Text to 
search field of the Internet tab will be used for the search. The number 
corresponds to the sequence number of the shortcut in Tools->Settings-
>Internet. 

From any Windows application, highlight the term searched, and press 
the key combination Ctrl+Ins followed by Ctrl+Alt+n, where the number n 
must be typed in the numeric keypad with Num Lock set. 
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Defining Internet 
Shortcuts 

Internet shortcuts are defined in Internet->Define Links. The shortcuts 
are very easy to define. Just follow these steps: 

1 Open the list of shortcuts in Internet->Define Links. To create a 
new entry, you just have to move down the keyboard cursor beyond 
the last entry with the arrow keys. 

 

2 Perform a search in the website source that you want to check.  For 
example, do a search in Google of a term, for example xbench. 

3 Copy the URL into the clipboard, for example, you URL may look 
like this: 

http://www.google.com/search?hl=en&lr=&ie=UTF-8&q=xbench 

4 Paste the URL into one entry of the window and replace the term you 
searched with a %s as shown below. In future queries that use this 
query string, ApSIC Xbench will replace the %s sequence with the 
search string. 

5 Assign a name to your shortcut by moving the cursor to the Name 
column and typing the name there. This name will appear in the 
Website field of the Internet tab and also in the Internet pull-down 
menu. 

6 If you wish to move the current entry down in the list (this has the 
effect of changing the hotkey number) you can click on the Up and 
Down buttons located on the bottom of the window. 
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If you run into an interesting link when you browse a page using the 
Internet tab of ApSIC Xbench, you can quickly add it to the list of pages 
by using the Internet->Capture URL menu item. 

If you have the tool bar turned on, a number of tool bar buttons appear 
that help you to browse Internet pages. One of these buttons allows you 
to open Internet Explorer with the same page you are looking at. This can 
also be done with Internet ->Open Browser or with the Ctrl+W hotkey. 
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Bugs and Suggestions 
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Reporting Bugs and 
Suggestions 

Your feedback on any errors in the program is most welcome. We are 
also open to suggestions as to how we can improve areas that you find 
confusing.  

Please send your bug report or suggestion to 
http://www.apsic.com/en/products_submit_bug.aspx 

Any information you send to us will be kept confidential and used solely 
to solve the problem. 
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